Email dispatcher slowness

Incident Report for Questline

Resolved

The issue has been resolved. We apologize for any inconvenience.
Posted May 07, 2026 - 20:38 EDT

Monitoring

We have identified the issue and are actively monitoring the situation. I patch release will be issued as soon as possible to resolve the slowness. Thank you for your patience.
Posted May 07, 2026 - 16:19 EDT

Investigating

Email campaigns are taking inordinate amounts of time to dispatch. We are investigating this issue.
Posted May 07, 2026 - 15:21 EDT
This incident affected: Engage (Engage Outbound Email).