Errors in Newsletter Editing
Incident Report for Questline
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 17:23 EST
Investigating
We are currently investigating reports of Errors during the Newsletter editing process. We will update this incident when the problem has been identified.
Posted Dec 09, 2019 - 13:59 EST
This incident affected: Engage (Engage Web Portal).